The New Minimized View

Moderator
VeraI 18974 2664 651
On the LingQ blog is the New Minimized View announced: http://lingqcentral-en.lingq.com/new-minimized-...

It is really nice getting some of the 'old' LingQ feeling back! I'm very glad about these changes. Thank you very much.

I've recognized some minor problems (tested with Firefox):
- If I tag a word the list of existing tags is not shown.
- When I looked up a second word in the dictionary (Babylon for English-German in this case), the first three or four lines of the definition were not shown. Looking up the first LingQ and going back solved the problem. I was not able to reproduce it, but I'll test more today.
June 2014
  • jungleboy 16810 17463 6625
    I like the minimised view but I have an issue as well now (either minimised or not): I can no longer select a word that isn't blue/yellow/underlined, and I can't select a phrase unless all words are blue/yellow/underlined. (Using Safari on a MacBook Air.)
    June 2014
  • [galina] 43 1070
    Thanks @Vera :) we will continue working on some minor issues. Let us know if you find any other bugs.

    @jungleboy - we will look into it. I seems to be an issue with highlighting any words and phrases multiple times. At a certain point it stops highlighting. Meantime, refreshing the page should temporary help. Sorry for the inconvenience!
    June 2014
  • silviad 533 2927 14729
    Yes, I would like to report a problem:

    1. Open a lesson.
    2. Click on the pensel before a hint.
    3. An empty box opens (WRONG of course)

    4. The next times when you click again on the pencil for another word, it shows the first word in the hint box. (WRONG of course).

    I hope this is clear enough.

    BTW I think this minimised view is an improvement! Thanks.

    Silvia

    June 2014
  • [galina] 43 1070
    @silviad - we will look into it. Thanks for the information!
    June 2014
  • Wulfgar 24740 8774 8494
    This isn't a good change for desk top!

    1) Why is the pop-up for blue words so big now? It obstructs more text. Please shrink it down to no bigger than it was before. Also, sometimes I can't close it, and have to resort to highlighting another word to make it go away. Please fix.
    2) Why does the pop-up for yellow words linger longer now? Please reduce the linger time back to what it was before.
    June 2014
  • Jingle 2316 23010 21066
    I'm happy too about the new minimized view since I have "stubbornly" continued to use LingQ in the "old" way,

    I agree that the the pop-for blue words is annoyingly large.

    And the pop-up when you choose "all words known" is annoying also at this point. (I suppose I can get used to it.) After I click o "all words known", I am usually not finished with the lesson - in other words not ready to do the things listed on the pop-up.

    It would be great if there would be one more choice: Return to top of page or lesson.
    June 2014
  • [galina] 43 1070
    @Wulfgar, @Jingle - thanks for your feedback guys! We continue working on it. There will be some improvements and additional adjustments. We are keeping your suggestions in mind.
    June 2014
  • Wulfgar 24740 8774 8494
    Also, after selecting the definition for one blue word, please don't scroll down to the next blue word. I often need to edit the definition, so please leave it on the word whose definition I just selected.
    June 2014
  • debbielim 2919
    When I'm going through a lesson on my phone, and create/save a LingQ, the page seems to refresh and 'scroll up' to the top of the page again. To get back to where I left off, I need to scroll all the way down again and find my spot.

    Is anyone else having this problem? Or am I doing something wrong? It's just particularly frustrating as my 'page' is also very long as it's a 25-page book chapter that I've imported! Thanks for any advice.
    June 2014
  • jolanda 38309 13878 23820
    @debbie
    are you using the newest update? It seems to be a old version.

    j;-)
    June 2014
  • debbielim 2919
    @jolanda
    I downloaded the app a couple of days ago from Google Play... but I will have a bit more of a play or maybe re-install and see if that fixes things. Thanks :)
    June 2014
  • [galina] 43 1070
    @Wulfgar - when you select a blue word, are you able to see a pencil icon left of a hint?

    @debbielim - we have pushed an update today. Please update your app from Google Play. It should fix some issues :)
    June 2014
  • Wulfgar 24740 8774 8494
    @galina - Yes. I tried this and if I hover over the definition the edit pencil appears. If I then select the pencil, I can edit it and it doesn't scroll. So I'll use that work around. But I'm not sure who would want the text to scroll; it would be easier to just click without having to think about the pencil.

    I think I read this already, but sometimes highlighting white words stops working, and the work around is to refresh the page, which is time consuming.
    June 2014
  • [galina] 43 1070
    Hi @Wulfgar - it seems that before the update it was differently for some members (including you) as we were testing two different options. Now it is the same for all members. To edit a hint before saving a LingQ, just click the pencil icon. Also, there is a shortcut "shift + Enter" which allows you to edit the definition before you save it.

    We have pushed another minor update today, so the issue with highlighting should be fixed now. If you still experience it, please let us know.
    June 2014
  • Moderator
    VeraI 18974 2664 651
    As I wrote in my first post I was really excited to get the minimized view back. When I clicked on "Search dictionary" the dictionary opened immediately. That was great! But with the latest change it does not open any longer immediately. I have to make a second click now on "Look up in a dictionary".

    There is still a tagging problem: if I tag a word the list of existing tags is not shown.

    - Tested with Firefox -
    June 2014
  • Jingle 2316 23010 21066
    I really like it that the lesson goes immediately to the minimized view for me.
    June 2014
  • [galina] 43 1070
    @VeraI - these issues are on our priority list. Hope to have them fixed soon!

    @Jingle - great to hear that! :)
    June 2014
  • [galina] 43 1070
    Hi Vera! Just want to let you know that the dictionary issue should be fixed. Now it should open automatically when clicking "search dictionary".
    June 2014
  • Moderator
    VeraI 18974 2664 651
    Thank you Galina! Sounds great. I'll test it.
    June 2014
  • Moderator
    VeraI 18974 2664 651
    I have a new problem. I've tested LingQ now on my ASUS Transformer Book T100. Everything works fine but I cannot open the dictinaries. Only a small single line window opens with an "x" to close it. Tested with IE 11 and the newest Firefox on Windows 8.1. The problem occurs in the full view and the minimized view as well.
    June 2014
  • Administrator
    mark 37941 2525 3880
    @Vera - I think this happens when your dictionary window is completely minimized. Can you try dragging the corners of the small dictionary popup that opens. You should be able to drag and open it up. We're not sure why this happens on some accounts but we will be pushing a minimum size for that popup in our next update. But, in the meantime, you should be able to drag and open it and then the size will be remembered.
    June 2014
  • murf93 2219
    hi I have sent an e-mail to support in respect of a issue I have with viewing lessons, both from my library and also from my imports.any help would be appreciated.
    June 2014
  • Moderator
    VeraI 18974 2664 651
    @Mark: Thank you Mark. That helped a lot. I tried it today with an USB mouse and I could enlarge the window. I was not able to do make this work with the touchpad or the touchscreen. I admit I'm not used to them.
    June 2014
  • Administrator
    mark 37941 2525 3880
    @murf93 - I haven't seen an email to support from you. Did you send it to support at lingq dot com?
    June 2014
  • davidked 41417 0
    Hi. I would just like to add too that I think the blue popup is way too big and I have trouble seeing it on my screen. Thanks. David
    July 2014
  • davidked 41417 0
    Hi, I also noticed the scroll with the arrows stops working for me whenever I roll over a blue word. ie:
    1) open lesson
    2) use arrows to scroll
    3) rollover a blue word
    4) scrolling stops working for me.

    Unfortunately, this makes lingq unusable for me whenever I am using my laptop, which is about 90% of the time. This is very frustrating to me because I want to study right now with lingq and I am unable.

    note, I tested in both firefox and ie and it doesnt work in either.
    July 2014
  • Administrator
    mark 37941 2525 3880
    @davidked - I'm not sure I follow what you are doing when you say you roll over a blue word. Are you clicking past it using the keyboard? Which view are you in minimized or maximized? Which browser? I don't really have any problems with scrolling. Have you tried ctrl+refreshing the page to clear you cache?
    July 2014
  • davidked 41417 0
    Hi Mark,

    Using firefox 30 and internet 11 - same behavior in both.
    Minimized view

    When I roll the cursor over a blue word and the popup box comes up I am unable to scroll further. Once I move the mouse over the word, in addition to the vocab popup, the word in the text will also be given a red border. As long as that red border is around the word I am unable to scroll with the arrow keys further.

    I can get the red box to disappear by either clicking a lingq word or by highlighting 2 other words together and then cancelling the box around those other words. Once I do this then the red box disappears and I can scroll with the arrows again.

    image of the red box around the word. Impossible to scroll with arrows when there is this box around a word.
    https://www.flickr.com/photos/90418608@N08/1455...
    July 2014
  • Moderator
    alex 1705 656 31848
    @davidked - Hmm, I'm not exactly sure what would be causing this. Is your cursor on the text portion of the screen, or is it off to the side?
    July 2014
  • Moderator
    alex 1705 656 31848
    @davidked - Ah, I see what you mean now. For some reason I thought you meant the left and right arrow keys weren't scrolling to the next word, but I realize you meant the up and down arrow keys.

    The up and down arrow keys are used for moving through the hints and other options on the blue popup. I'm not sure that this is an easy fix, since the site is now reserving these keys as keyboard shortcuts instead of their standard function of moving up and down on the page. Instead, I would actually recommend turning on auto-scroll, then just using the left and right arrow keys to move between your new words. This will automatically scroll up or down in the text as you move through your blue words.

    Most laptops have a scroll option as well, often used by sliding up or down on the right-hand side of the trackpad. Hopefully yours isn't broken!
    July 2014
  • jungleboy 16810 17463 6625
    Hi guys,

    I also have a problem with the arrow keys. I regularly change the hints, and I want to use the left and right arrow keys with alt to move around in the hint box as I do in all other tasks I do with text. But using the arrow keys in this way seems to make the system think that I want to move through my lingQs, so before I've finished adjusting the hint it has taken me to the next/previous lingQ (and usually not just the next one but two or three ahead/behind). Unfortunately this is becoming quite frustrating and I can't really change lifetime habits for how to move through text quickly.

    FYI, I'm using Safari (7.0.5) on a Mac.

    Thanks!
    July 2014
  • Moderator
    alex 1705 656 31848
    @jungleboy - As long as I click in the Hint field first, it seems to function properly. Would you be able to take a screencast of this (using something like Jing: www.techsmith.com/jing.html) so I might have a better idea of the issue?
    July 2014
  • davidked 41417 0
    Hi Alex,

    Unfortunately, this makes lingq almost unusable for me on my laptop, after using it heavily for about 4 years, due to my physical limitations (at least to the way I use it now - maybe I can retrain myself). I am very grateful for lingq as it has helped my Russian tremendously and thus I am very hesitant to criticize. However, the site sometimes violates good design principles. imho - the site appears to be going for this very cool feel, which it often achieves, but at the expensive of usability, performance and code stability/maintainability. I design and build applications for a living and every time I go for cool at the expense of sound principles I get burned - which sadly happens more often than it should. lol.

    I just discussed the lingq arrow issue with my UI/UX person and with my top developer and we are in agreement to the following:

    There are strong reasons universal web and computer standards exist - usability, consistency, ADA, etc. This is why the arrow keys, enter, mouse/mouse buttons, scroll bars, etc behave the same across every site and every application. To co-op a universal web standard when different options exist is a design sin. The proper method, or most likely candidate, for jumping from one element to the next is with the tab key. At worst, if you are going to co-op then different keys should be wired up to scroll up and down as a good keyboard design will never require the user to use a mouse (see below).

    I recommend that your designers read msdn.microsoft - Guidelines for Keyboard User Interface Design
    http://msdn.microsoft.com/en-us/library/ms97132...

    If you ever want a user with lots of design experience to provide either help or input please let me know.

    David

    p.s. I hope the tone of this does not come off wrongly. I am a big fan of lingq.
    July 2014
  • Moderator
    alex 1705 656 31848
    @davidked - Thanks for your comment. I see now what you mean. I was under the impression initially that this was the case on purpose, but one of our developers confirms this is likely a bug, as there is no reason the up/down arrows need to be reserved for another function when the blue popup is closed in minimized view. I don't know that we have a lot of users who are affected by this, but we'll see what we can do to get this taken care of in a timely manner.

    Regarding the overall keyboard shortcuts, we've had the same keyboard shortcuts for right around two years now, so I think any changes to these will be met with quite a bit of resistance (and confusion!).
    July 2014
  • Wulfgar 24740 8774 8494
    Is the auto-scrolling thing really necessary? It's driving me nuts. I create a link, then it scrolls the page down to the next blue word, often making me lose my place. I can't imagine someone actually wanting that feature.
    July 2014
  • Moderator
    alex 1705 656 31848
    @Wulfgar - You can turn auto-scroll off by clicking on the gear icon next to the audio player then selecting this option in the dropdown. It'll remember whichever setting you select, so you only have to do this once :)
    July 2014
  • Administrator
    mark 37941 2525 3880
    @wulfgar - You can turn auto-scrolling off in the gear dropdown on the lesson page.
    July 2014
  • Jingle 2316 23010 21066
    In older versions, the lingq popups sometimes appeared below the word and sometimes above if I remember right. Now they always appear below.

    This causes me a small problem with blue words because when I read fairly easy material I like to lingq as I read and listen. The blue box covers up the text making this impossible. So I have given that up.

    The bigger problem is with yellow words. When I am reading and listening to hard material, I often need to check what a yellow word means. The combination of popups appearing below the word and the slight lag time for the box to close makes this difficult because the the next part of the text is covered up. And then, particularly in Russian where I am still battling with Cyrillic, I lose my place as well.

    If I use the expanded view to see the definitions of yellow words, I still have the problem of losing my place and focus because of having to shift my sight to the right side.

    In short, it would be very nice (for me) if the popups popped up above the words.
    July 2014
  • Moderator
    alex 1705 656 31848
    @Jingle - I see what you mean, but I also want to point out that when you hover over a word there is a red border that appears around that word. If you move off the popup so it disappears, the word should still have a red border around it.

    Another alternative is just to use the space bar. When moving through your LingQs or new words with the left/right arrow keys, you can use the space bar to open the popup and the space bar to close it again. If you hover over a word with your mouse and see the popup, just press the space bar twice to close the popup without having to move your mouse.
    July 2014
  • Jingle 2316 23010 21066
    @Alex - Wow! You apparently think I can walk and chew gum at the same time! (There's a good phrase for English learners!) OK, I'll try using the space bar. When I tried it out just now,it took so much concentration to coordinate mouse and space bar I lost my place anyway! Maybe I'll learn...

    The problem is that I'm trying to keep up with the recording as I do this AND trying to read Cyrillic makes it particularly difficult for me. The red box might be somewhat helpful, but by the time I've managed to clear the popup the recording is at least a line if not two ahead.

    It works OK when the popup is above the word. It seems kind of funny that when one of the main uses of the lesson page is to read and listen, you'd cover up where you're trying to read. ;)

    Thanks for your reply. I just thought I'd bring someone's attention to the "problem". No one else has mentioned it so I must use LingQ in a nonstandard way. Or be slow.
    July 2014
  • Moderator
    alex 1705 656 31848
    @Jingle - Ah, that would make much more sense. I didn't realize you were playing the audio at the same time ;)

    I don't think it's that you're slow. I'd probably have the same problem in Korean and I've been at it for many years. What I might recommend is if you come across a word you don't know, either pause the audio to review it or just click the "jump back" button, which will rewind the audio I believe 10 seconds to allow you to re-listen to that specific section.

    Anyway, I'm just throwing out a few suggestions here and there in case one might actually help you use the site more effectively. We can of course make this change too, but as you say it hasn't been a very common request (first time, actually), so minor adjustments to how you use the site will actually be the most helpful at solving this problem :)
    July 2014
  • Jingle 2316 23010 21066
    And thanks for the suggestions.
    July 2014
  • Wulfgar 24740 8774 8494
    Two issues are still really causing me headaches:
    1) After creating a lingq, I can't turn off the pop-up, meaning the "X" doesn't work. Sometime it fades away on its own, but not always. The work around is to hover over a yellow word, for which I can turn off the pop-up.
    2) The little edit pencil recently stopped working. I can select it, but the effect is the same as creating a lingq; the edit window doesn't pop up. The work around is to select the underlined text after creating the lingq.
    August 2014
    • Moderator
      alex ca Canada 1705 656 31848
      We've got the second issue on our list and hope to have it fixed soon!
      For the first issue, I can't seem to quite reproduce this. Do you notice this happening frequently? If so, would you be able to provide a bit more information on which exact steps you're taking?
      August 2014
    • Moderator
      alex ca Canada 1705 656 31848
      Never mind, I see the issue with the popup not disappearing!
      August 2014