Keyboard shortcut "x" (ignore) is not working for me any more.
eugrus 17101 40961 3160
^
August 2014
  • Moderator
    alex 1705 656 31848
    I checked and it looks to be working properly over here. Answers to a few questions should help us narrow things down!

    Which browser you're using?
    Are there any errors showing in the error console?
    Is this happening in multiple lessons, or only a specific lesson?
    August 2014
    • eugrus ru Russian Federation 17101 40961 3160
      Chrome 36.0 for Windows.
      Here is the console data: http://pastebin.com/wyGPdLzf
      I am experiencing it in every single lesson, as long I can tell.
      August 2014
      • Moderator
        alex ca Canada 1705 656 31848
        Ah, thanks! Looks like it's just an issue in minimized view for some reason. We'll get this fixed!
        August 2014
    • eugrus ru Russian Federation 17101 40961 3160
      In IE it works fine.
      August 2014
    • OzzyHellBack us United States 15 0 6
      X button works for me, so could it be that your X button might be broken?
      August 2014
      • eugrus ru Russian Federation 17101 40961 3160
        I would notice, as it would make searching for XXX complicated =)
        August 2014
  • eugrus 17101 40961 3160
    Once again, the shortcut is not working. Here is a JS-console sample of me trying to ignore the word "Android": http://pastebin.com/Yz8xXpvs
    February 2015
    • Administrator
      zoran rs Serbia 2328 480 89
      Thanks for reporting this. I've provided your JS-console sample to our team, and it should be fixed soon.
      February 2015
      • eugrus ru Russian Federation 17101 40961 3160
        So how is it going?
        March 2015
        • Administrator
          zoran rs Serbia 2328 480 89
          Hi,
          I am really sorry about this. We were having trouble reproducing this, which makes things lot more diffucult to fix. We are making some changes to the Lesson page that we hope will continue improving things.
          March 2015
  • therightcoast 15058 0 649
    I cannot ignore word by keyboard nor mouse. I'm also using Chrome. There seems to be some trouble with the pop-up menu when I place the pointer on an unknown word. The box disappears quickly and i cannot click the search dictionary button.
    March 2015
    • Administrator
      zoran rs Serbia 2328 480 89
      I am sorry to hear that you're having problem with this. You are not able to ignore words at all, or only sometimes?
      March 2015
      • eugrus ru Russian Federation 17101 40961 3160
        Both the shortcut and button work poorly, that's mostly not both in Chrome and Firefox.
        April 2015
  • Moderator
    alex 1705 656 31848
    Hi guys! After some additional testing today, we found another issue that was causing some issues on the page to appear after a specific set of actions. I've reported this as well to our development team, and we'll try to make some progress on this in the next week or so.

    I'll let you know when this should be fixed!
    April 2015
    • Moderator
      alex ca Canada 1705 656 31848
      We've released some updates today that should hopefully help with this! Please let us know if you're still encountering issues here.
      April 2015
      • eugrus ru Russian Federation 17101 40961 3160
        It only works for a lingq after I click on it. Once the next lingq is selected (other then by clicking right on it) the x-shortcut does nothing.
        April 2015
        • Moderator
          alex ca Canada 1705 656 31848
          Hmm, I inquired again with our dev. team on this, and they noted that we've made some adjustments on our end to improve the reliability here, but the remaining issues with this appear to be issues with a third-party library we are using on the lesson page.

          Sorry we can't be of more help in the immediate term here, though hopefully this third-party library is updated soon to resolve the remaining issues here that are preventing this from working properly!
          April 2015
          • eugrus ru Russian Federation 17101 40961 3160
            If you would like to see my problems structured to get the final idea of what you can do about it and what not, there are basically several issues:
            1. Ignoring using the x-key only works after I put the mouse on that certain lingq and see its hint.
            2. In most cases the on-screen "Ignore this word" button doesn't work by clicking on it, so I use the x-key in the way described above or choose this very same "Ignore this word" button by using arrow keys while the lingq is hovered over.
            3. Sometimes even the x-key doesn't work whatever (see 1.) I do. Then the only way is to use the arrow keys.
            4. Sometimes I also can't create a hint by clicking on the button. Then again I have to use arrow keys to select the button via keyboard.

            I am trying to stay constructive about it, but LingQ is definitely the most ticky-tacky piece of software I happen to use and I really have the feeling that it is getting worse every year. It's probably some kind of madness that I am still paying for it while not being able to use it most of times and having to write tones of bug reports, that mostly bring nothing.
            April 2015
            • Moderator
              alex ca Canada 1705 656 31848
              Thanks for the detailed reporting here, and I certainly understand your frustration. This explanation of activities does help, however, to give a better idea of why some of these issues are occurring.

              I'll respond to each item separately so as to keep things organized!

              1) I'm really sorry about this one. I didn't quite understand the nature of this issue, though as I attempt this again I see the issue you are running into. I don't remember exactly when, but I believe some time last year the behavior here was changed. Previously the keyboard shortcuts all worked properly when the popup was closed, but we had some complaints that users who pressed "Enter" were accidentally saving multiple words without having seen any hints (as the "Enter" key would save a LingQ with the first selected hint).

              I inquired further here, and in order to address this issue we had to disable keyboard shortcuts specific to the blue popup when the popup was closed (as there wasn't an easy way to pick and choose which ones work at which time). The choice between these two led us to disable blue-popup keyboard shortcuts until the popup was visible, either by hovering over the word or pressing the space bar when the word was highlighted by the red border.

              This one's a bit tricky to solve from a usability perspective. I certainly understand your frustration here, as it's natural to expect that the keyboard shortcuts will work properly when the blue popup is visible. The number of reports we had of this the first time around, however, makes us initially a little reluctant to touch anything here. That being said, we have done a lot to fix various issues on the lesson page (it's a very complicated page), so now that stability is improved it may make sense at some point to look again at switching it back - though I don't know that this will happen immediately.

              2) There were some issues here previously, though it seems to have largely been resolved - at least from my attempt to reproduce this just now. Here's a quick screencast of me ignoring some words in a lesson:
              http://screencast.com/t/BqFXXfAgT5T

              Does your method of usage with the mouse look slightly different from mine in some way?

              3) I also tried reproducing this one but was unsuccessful. Is this with the popup open, or as per #1 is this being attempted when the popup is closed?

              4) I'm also not sure what would be causing this one, as I can't reproduce it either after our recent fixes. Would you try with just the keyboard and no mouse and see if it works for you?
              April 2015