Android app issues
My LingQ Android app doesn't work well. When I try to open lessons, some of them appear but others not, even in the same course. I don't know if it's only my problem or a general issue.
July 2014
  • Moderator
    alex 1705 656 31848
    @josemaria92000 - Hmm, I haven't heard any other reports of this. I tested myself and everything seems to be showing up properly. It should be showing the exact same courses and lessons as show on the Learn page on the site.

    If you're still having trouble with this, would you take a screenshot of the list in the app and a screenshot of the Learn page so we can see which courses/lessons aren't showing up?
    July 2014
    • josemaria92000 es Spain 46245
      Hi Alex! Maybe I haven’t explained myself correctly. The list of courses in the app is ok (it shows up the same list as on the Learn page on the site). The list of lessons in every course is also ok. The problem is when I try to open a lesson: lots of them don’t open. I don’t know why some of them can be opened while others can’t. Maybe it's a problem with my imported lessons, I'm not sure. I've been using the app mainly with my imported lessons.
      August 2014
      • Moderator
        alex ca Canada 1705 656 31848
        Ah, I see :) Thanks for the clarification! In that case, I'd be interested to know whether these lessons open properly on the site or not. In either case, please send me a link to the course and a lesson that you're trying to open that isn't working so I can take a closer look into this!
        August 2014
        • josemaria92000 es Spain 46245
          All the lessons open properly on the site (either imported or LingQ lessons). In the app, however, lots of them don’t open. For example, in my imported course “Philosophy for Everyone” (http://www.lingq.com/learn/en/library/courses/1...) lesson 4 “Morality” can be opened, while lesson 3 “What is it to have a mind” can’t be opened. It happens all the time, at least in my imported lessons. I have been researching, but I don’t find any pattern in this issue. It seems to be somewhat erratic.
          August 2014
          • Moderator
            alex ca Canada 1705 656 31848
            Thanks for the additional info! I think this is actually related to an issue that should be fixed in the next version (coming very soon). The issue is that longer lessons are timing out and therefore not loading properly. I notice Lesson 4 is shorter than Lesson 3, so it's likely to be this issue. When the new version is released please try this again and let us know if it's working!
            August 2014
            • josemaria92000 es Spain 46245
              I agree. I think it is a time out problem. I’ve tested the app to check this, and I’ve found that, if split, the lessons can be opened. In my case, the “safe length” of the lessons must be around 1000 words. I have had to split in such a way the lesson I was working with in the app to be able to open it without problems. I hope it will be fixed soon.
              Greetings and have a good summer!
              August 2014