Why must I click twice?

mocqgn gb United Kingdom

I have recently noticed the app and website functionality changed somewhat. When i set a word to known (by pressing K on website or setting to known on the app) it often reverts back to the previous status 2 seconds later and i need to press it it again. This also happens when i set to status 3, 4, etc.

September 29 at 10:01
  • SergeyFM ru Russian Federation

    Recently this happens to me too - pressing K does not always mark the word as known.

    September 29 at 13:44
  • Car2017 de Germany

    Same here. It happened from time to time before.

    September 29 at 14:22
  • Gio.Lorenzo it Italy

    This happens to me too in the last couple of days

    September 29 at 15:47
  • Administrator
    zoran rs Serbia

    Does it happen only if you try to change the status of a yellow word and make it known? Or it happens to blue words too? How often exactly that happens? I just tested on Google Chrome and marked tons of blue and yellow words known but not even once that issue occurred. I am trying to figure out how to reproduce it.

    September 29 at 23:46
    • Gio.Lorenzo it Italy

      It seems that when blue words turned into yellow, they almost always stay yellow. Yet, today when I opened a lesson I left uncompleted yesterday, 3 or 4 words that I lingqed yesterday were back blue again. I was at about 10th or 15th page of lesson when I left yesterday, but got turned to 2nd page of the lesson since blue word appeared there. The behaviour of the system is very similar to when the internet connection is slow (lingqing is undone when moving on quick if connection is slow). However, I tried it on different connections and different devices (on which I checked that internet connection was fast) and the problem persists.

      September 30 at 00:13
    • deadlywisdom au Australia

      I've had it happen on android the last couple of days. Usually happens when I change the statues of a yellow word, after a few seconds it reverts back

      September 30 at 00:24
      • marcossfernandes br Brazil

        Yes, for sure it is really happening. I got the same here on the Android App.

        October 01 at 01:52
    • ericb100 us United States

      I've definitely noticed in the app (android 9). I think I've mostly noticed when going from yellow to known. I'll click one or two words to known and I notice as I read a bit more than they've switched back to yellow. It *may* be happening after switching focus to another app and coming back. It catches me off guard, but I'll try to get more specific details when it happens again.

      September 30 at 00:41
      • ericb100 us United States

        I tested again on the app. It is happening when I click a yellow word and either make it known or change it to another level of yellow. The coint count numbers flash, but if I click back on the word it's reverted back to its original level of yellow. Also if I change focus (minimize and bring the app back up again) it will have reverted back to it's previous color.

        As a separate test I tried moving a known word back to unknown. That appears to work correctly. Something has definitely changed and it's been the last few days or so.

        I've also tried on Chrome 77. It definitely is happening if I convert a word from yellow to known. It will flash to the new "color" and then within a second the color reverts back and the level is back to the old level. If I click it once more to known then it stays. I can then click it to unknown, known, etc. with it keeping the level each time. I have seen this when increasing the level of yellow (say from 3 to 4), but this seems to be much more inconsisent on whether it will revert. Possibly these are words I've already changed successfully before.

        September 30 at 13:20
        • marcossfernandes br Brazil

          Yes same here. I did not do a test like you did, but it seems to be the same

          October 01 at 01:56
    • Car2017 de Germany

      I'm using Firefox on Windows 10 and it happens when I review vocabulary, mostly when it increases to known, but not only. It happens often enough, but sometimes more, sometimes less often.

      September 30 at 07:56
    • SergeyFM ru Russian Federation

      I'm using Chrome on Windows. Tried on two computers.

      It goes on like this:

      I click on the yellow word,

      press K,

      the label with a coin shows up +4,

      the word is still yellow,

      optional: I click next word and see that first word is still yellow, click it again,

      press K, it loses its color, I see the label with a coin again, known-worlds-counter increases.

      BTW, I just noticed that blue words marked as known do not go to my Daily Goal! It doesn't feel right, and it means I have to create a link and only thereafter mark it as known.

      UPDATE: It happens very often now :(

      I click K on a yellow word, it looks like it went to a known status, and the next second it reverts to yellow. If I press K again - it works as intended.

      The same happens in a completely new session in Incognito Chrome mode.

      It is annoying.

      September 30 at 09:12
      • Administrator
        zoran rs Serbia

        @SergeyFM Daily Goal includes only LingQs created, not Known words. That was always the case and nothing has changed there.

        I still can't reproduce this, but I will report it to our team and hopefully they will be able to figure it out.

        September 30 at 16:47
  • emde33 pl Poland

    This happens to me both in Android and Windows. I click a yellow word to change it status, the audio plays twice and if I click it right away, I can see that the status stays the same. If I don't click anything it will revert back to original status on its own. The second change of status makes it permanent.

    September 30 at 12:04
    • Administrator
      zoran rs Serbia

      @emde33 Thanks. I will report this to our team and hopefully they will find the issue and have it fixed.

      September 30 at 16:47
      • emde33 pl Poland

        I should mention perhaps that I am using the sentence mode.

        Something new I discovered today is that in android it might have something to do with switching screens. I haven't tested this out a lot, but I think the app might start normally and only after you switch the screen off, get back to main screen or switch to a different app for a moment this "click twice" bug appears. Also I am fairly certain that the second time around clicking away makes the lingq app run normally.

        A similar thing used to happen with text-to-speech on my phone. When I would go away for a moment from LingQ to check some word in an external dictionary app, the text-to-speech module would not work. I had to switch apps again and it would be running again, without any problems

        October 01 at 13:06
        • ericb100 us United States

          I thought initially it was happening on "switching screens" or focus as well, but you'll find it is not. You can click the same word again and find it has reverted back to its previous level without changing screens. I also use sentence mode a lot, but the issue is still there in full paragraph mode.

          October 01 at 14:01
  • mrosenston us United States

    I don't use the app. I use linq on my computer and it happens there too. If I mark a word known it goes back to unknown and I have to click it again.

    October 01 at 16:30
    • marcossfernandes br Brazil

      I have read a pretty small text now, and mark one lingQ known. And the glitch happened again, I clicked it again and turned it into a known word, but my lingQ learned count did not count it and remained zero, even though the word is a know (white) word now.

      This time I was using Firefox on the computer.

      October 01 at 18:35
  • patrick1978 nl Netherlands

    Same here. It happens every single time i change the status of a yellow word.

    October 01 at 19:30
  • patrick1978 nl Netherlands

    It is still happening. It makes Lingqing extremely frustrating.

    October 03 at 04:39
    • marcossfernandes br Brazil

      The same here, on all my devices and, yes It makes Lingqing extremely frustrating.

      October 03 at 19:21
      • Ginkgo58 au Australia

        It's happening for me also!

        Tuesday at 07:39
        • ericb100 us United States

          Try logging out and logging back in. Maybe even uninstall and reinstall the app. That helped me. I was doing it for another reason but I think it ended up potentially fixing it as I haven't had the issue on the app in a few days. I'm not sure about the website.

          Tuesday at 14:01
  • emde33 pl Poland

    It's working for me now as intended both in the app and on the web page. I updated the app and then I had to log off and log in again. It seems to me that this sort of a reset has fixed the bug

    Tuesday at 13:03
  • marcossfernandes br Brazil

    It seems to me that the problem is no longer happening.

    Was something done by the lingQ technical team or was it pure luck that it is working?

    Wednesday at 20:35
    • SergeyFM ru Russian Federation

      I can confirm that, many thanks to devs! Though I'd appreciate if we were kept informed.

      Wednesday at 20:49
  • Administrator
    zoran rs Serbia

    The issue has been fixed a few days ago. Sorry guys, I was sure that I did posted here. I guess I only messaged users who complained via email. My bad.

    Anyway, I am glad you noticed it works properly now!

    Wednesday at 21:28
    • marcossfernandes br Brazil

      Awesome thank you very much!

      Wednesday at 23:26