It looks like you are using an old version of Internet Explorer. Sorry, we only support IE 10 and above. To use the site you will need to use a more up to date browser. We strongly recommend you upgrade to:

Go to page: « 1 2

Hi. I would just like to add too that I think the blue popup is way too big and I have trouble seeing it on my screen. Thanks. David

Hi, I also noticed the scroll with the arrows stops working for me whenever I roll over a blue word. ie:
1) open lesson
2) use arrows to scroll
3) rollover a blue word
4) scrolling stops working for me.

Unfortunately, this makes lingq unusable for me whenever I am using my laptop, which is about 90% of the time. This is very frustrating to me because I want to study right now with lingq and I am unable.

note, I tested in both firefox and ie and it doesnt work in either.

@davidked - I'm not sure I follow what you are doing when you say you roll over a blue word. Are you clicking past it using the keyboard? Which view are you in minimized or maximized? Which browser? I don't really have any problems with scrolling. Have you tried ctrl+refreshing the page to clear you cache?

Hi Mark,

Using firefox 30 and internet 11 - same behavior in both.
Minimized view

When I roll the cursor over a blue word and the popup box comes up I am unable to scroll further. Once I move the mouse over the word, in addition to the vocab popup, the word in the text will also be given a red border. As long as that red border is around the word I am unable to scroll with the arrow keys further.

I can get the red box to disappear by either clicking a lingq word or by highlighting 2 other words together and then cancelling the box around those other words. Once I do this then the red box disappears and I can scroll with the arrows again.

image of the red box around the word. Impossible to scroll with arrows when there is this box around a word.

@davidked - Hmm, I'm not exactly sure what would be causing this. Is your cursor on the text portion of the screen, or is it off to the side?

@davidked - Ah, I see what you mean now. For some reason I thought you meant the left and right arrow keys weren't scrolling to the next word, but I realize you meant the up and down arrow keys.

The up and down arrow keys are used for moving through the hints and other options on the blue popup. I'm not sure that this is an easy fix, since the site is now reserving these keys as keyboard shortcuts instead of their standard function of moving up and down on the page. Instead, I would actually recommend turning on auto-scroll, then just using the left and right arrow keys to move between your new words. This will automatically scroll up or down in the text as you move through your blue words.

Most laptops have a scroll option as well, often used by sliding up or down on the right-hand side of the trackpad. Hopefully yours isn't broken!

Hi guys,

I also have a problem with the arrow keys. I regularly change the hints, and I want to use the left and right arrow keys with alt to move around in the hint box as I do in all other tasks I do with text. But using the arrow keys in this way seems to make the system think that I want to move through my lingQs, so before I've finished adjusting the hint it has taken me to the next/previous lingQ (and usually not just the next one but two or three ahead/behind). Unfortunately this is becoming quite frustrating and I can't really change lifetime habits for how to move through text quickly.

FYI, I'm using Safari (7.0.5) on a Mac.


@jungleboy - As long as I click in the Hint field first, it seems to function properly. Would you be able to take a screencast of this (using something like Jing: so I might have a better idea of the issue?

Hi Alex,

Unfortunately, this makes lingq almost unusable for me on my laptop, after using it heavily for about 4 years, due to my physical limitations (at least to the way I use it now - maybe I can retrain myself). I am very grateful for lingq as it has helped my Russian tremendously and thus I am very hesitant to criticize. However, the site sometimes violates good design principles. imho - the site appears to be going for this very cool feel, which it often achieves, but at the expensive of usability, performance and code stability/maintainability. I design and build applications for a living and every time I go for cool at the expense of sound principles I get burned - which sadly happens more often than it should. lol.

I just discussed the lingq arrow issue with my UI/UX person and with my top developer and we are in agreement to the following:

There are strong reasons universal web and computer standards exist - usability, consistency, ADA, etc. This is why the arrow keys, enter, mouse/mouse buttons, scroll bars, etc behave the same across every site and every application. To co-op a universal web standard when different options exist is a design sin. The proper method, or most likely candidate, for jumping from one element to the next is with the tab key. At worst, if you are going to co-op then different keys should be wired up to scroll up and down as a good keyboard design will never require the user to use a mouse (see below).

I recommend that your designers read - Guidelines for Keyboard User Interface Design

If you ever want a user with lots of design experience to provide either help or input please let me know.


p.s. I hope the tone of this does not come off wrongly. I am a big fan of lingq.

@davidked - Thanks for your comment. I see now what you mean. I was under the impression initially that this was the case on purpose, but one of our developers confirms this is likely a bug, as there is no reason the up/down arrows need to be reserved for another function when the blue popup is closed in minimized view. I don't know that we have a lot of users who are affected by this, but we'll see what we can do to get this taken care of in a timely manner.

Regarding the overall keyboard shortcuts, we've had the same keyboard shortcuts for right around two years now, so I think any changes to these will be met with quite a bit of resistance (and confusion!).

Is the auto-scrolling thing really necessary? It's driving me nuts. I create a link, then it scrolls the page down to the next blue word, often making me lose my place. I can't imagine someone actually wanting that feature.

@Wulfgar - You can turn auto-scroll off by clicking on the gear icon next to the audio player then selecting this option in the dropdown. It'll remember whichever setting you select, so you only have to do this once :)

@wulfgar - You can turn auto-scrolling off in the gear dropdown on the lesson page.

In older versions, the lingq popups sometimes appeared below the word and sometimes above if I remember right. Now they always appear below.

This causes me a small problem with blue words because when I read fairly easy material I like to lingq as I read and listen. The blue box covers up the text making this impossible. So I have given that up.

The bigger problem is with yellow words. When I am reading and listening to hard material, I often need to check what a yellow word means. The combination of popups appearing below the word and the slight lag time for the box to close makes this difficult because the the next part of the text is covered up. And then, particularly in Russian where I am still battling with Cyrillic, I lose my place as well.

If I use the expanded view to see the definitions of yellow words, I still have the problem of losing my place and focus because of having to shift my sight to the right side.

In short, it would be very nice (for me) if the popups popped up above the words.

@Jingle - I see what you mean, but I also want to point out that when you hover over a word there is a red border that appears around that word. If you move off the popup so it disappears, the word should still have a red border around it.

Another alternative is just to use the space bar. When moving through your LingQs or new words with the left/right arrow keys, you can use the space bar to open the popup and the space bar to close it again. If you hover over a word with your mouse and see the popup, just press the space bar twice to close the popup without having to move your mouse.

@Alex - Wow! You apparently think I can walk and chew gum at the same time! (There's a good phrase for English learners!) OK, I'll try using the space bar. When I tried it out just now,it took so much concentration to coordinate mouse and space bar I lost my place anyway! Maybe I'll learn...

The problem is that I'm trying to keep up with the recording as I do this AND trying to read Cyrillic makes it particularly difficult for me. The red box might be somewhat helpful, but by the time I've managed to clear the popup the recording is at least a line if not two ahead.

It works OK when the popup is above the word. It seems kind of funny that when one of the main uses of the lesson page is to read and listen, you'd cover up where you're trying to read. ;)

Thanks for your reply. I just thought I'd bring someone's attention to the "problem". No one else has mentioned it so I must use LingQ in a nonstandard way. Or be slow.

@Jingle - Ah, that would make much more sense. I didn't realize you were playing the audio at the same time ;)

I don't think it's that you're slow. I'd probably have the same problem in Korean and I've been at it for many years. What I might recommend is if you come across a word you don't know, either pause the audio to review it or just click the "jump back" button, which will rewind the audio I believe 10 seconds to allow you to re-listen to that specific section.

Anyway, I'm just throwing out a few suggestions here and there in case one might actually help you use the site more effectively. We can of course make this change too, but as you say it hasn't been a very common request (first time, actually), so minor adjustments to how you use the site will actually be the most helpful at solving this problem :)

And thanks for the suggestions.

Go to page: « 1 2

To comment login or sign up for a free account